Home > SCCM Operating System Deployment (OSD) > SCCM Operating System Deployment – HTA connecting to SQL DB Error

SCCM Operating System Deployment – HTA connecting to SQL DB Error


 
Problem:
In WinPE I built an HTA and had a media hook on my boot image.  The HTA connects to my MDT database but once in WinPE I received the following error:
 
 "Safety settings on this machine prohibit accessing a data source on another domain."
 
After more time searching than I care to admit I found that "Access Data Sources Accross Domains" had to be set within WinPE and to determine the reg key (since WinPE is not on the domain and cannot leverage GP) decided to do a capture with procmon.  Below is the registry key I had to modify.  I scripted the registry change within WinPE in the HTA code for this instance and everything is working now.
 
This is likely due to my upgrading to SCCM 2007 SP2 and the Win PE instance being upgraded to a newer version – but then again that is just a guess on my part.
 
Fix:

HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionInternet SettingsZones3

Create a REG_DWORD key 1406 and set it to 0

 

Advertisements
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: